NEWS

LEADING FUTURE WEALTH

INDUSTRY CASE

行业案例

思科交换机配置vlan以及trunk的方法详解

2017/12/22 15:32:52

一、vlan的相关配置

vlan数据库配置模式
switch#vlan database
switch(vlan)#vlan 20 name caiwu(VLAN名称可选)
switch(vlan)#exit

VLAN全局配置模式
switch#config t
switch(config)#vlan 20
switch(config-vlan)#name caiwu(vlan名称可选)
switch(config-vlan)#exit


要删除id为20的vlan,只需要使用no vlan vlan-id命令
例:switch#config t
switch#no vlan 20
也可以在vlan数据可以中删除vlan

switch#vlan database
switch#no vlan 20

将接口加入vlan
switch#config t
switch(config)#interface f0/1
switch(config-if)#switchport mode access
switch(config-if)#switchport access vlan 20
switch(config-if)#exit

验证vlan的配置
show vlan brief

在模拟器中验证vlan配置的命令:
show vlan-switch brief


二、vlan trunk
switch(config)# interface f0/1(与另一个交换机相连接的接口)
switch(config-if)#switchport mode trunk

思科交换机默认的是自动协商,但是如果和其他的设备相互连接的话,就应该配置封装类型
switch(config)#switchport trunk encapsulation{isl|dotiq|negotiate}

如果不需要Trunk传送某个vlan的数据,可以从trunk中删除这个vlan:
switch(config-if)#switchport trunk allowed vlan remove vlan-id
也可以在trunk上添加某个vlan

switch(config-if)#switchport trunk allowed vlan add vlan-id

验证接口模式
show interface trunk
返回

Copyright©江西科创智能科技. All rights reserved. Powered by http://www.0791idc.com